LogTen Pro's "Two Generation" Policy on Operating System Compatibility

Follow

Our policy is to support the two most recent generations of Apple operating systems on the Mac, iPhone and iPad. This means that as of February, 2019 LogTen Pro is compatible with macOS 10.13 “High Sierra”, and 10.14 “Mojave” on the Mac app and iOS 11 and 12 on the iPhone and iPad app. When macOS 10.15 is released, we will stop supporting 10.13 “High Sierra”, and when iOS 13 is released we will discontinue support for iOS 11.

For every version of the system we want to support, we have to maintain devices and development tools for building and testing LogTen Pro on that system. With 99% of customers using either the current system, or one revision back, it’s not practical to invest the huge amount of time and effort required to ensure compatibility with systems older than that.

Apple is constantly updating their operating systems and it's important to keep up to date with the latest system, both for users and developers. New system updates don’t just add great new features, they ensure the safety and security of your data. By keeping up to date we can all take advantage of the latest technology both in terms of the speed at which LogTen Pro X operates and the features it offers pilots.

If you are still using an earlier operating system on your device, we highly recommend taking advantage of the free updates offered by Apple.

0 out of 0 found this helpful

Comments

0 comments

Article is closed for comments.